- From: Marco Bonola <
>
- To: "
" <
>
- Subject: lab 9-11-2020 bgp local pref
- Date: Thu, 12 Nov 2020 19:17:01 +0100
Dear students,
please find attached the configuration files for the lab we did today.
HOMEWORK:
1) add R8 into AS 40
2) configure IP addresses
3) configure OSPF
4) configure BGP
5) change the current iBGP configuration and instead of creating an iBGP
full mesh make R4 the route reflector for AS 40
6) test if everything works
Ciao
Marco
!
!
!
!
!
!
!
!
!
!
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 100.0.0.1 255.0.0.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 10.1.2.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.1.3.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 100.0.0.0
neighbor 10.1.2.2 remote-as 20
neighbor 10.1.3.2 remote-as 30
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
!
!
!
!
!
!
!
!
!
!
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 20.0.0.1 255.0.0.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 10.1.2.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.2.4.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 20
no synchronization
bgp log-neighbor-changes
network 20.0.0.0
neighbor 10.1.2.1 remote-as 100
neighbor 10.2.4.2 remote-as 40
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
!
!
!
!
!
!
!
!
!
!
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 30.0.0.1 255.0.0.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 10.1.3.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.3.6.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 30
no synchronization
bgp log-neighbor-changes
network 30.0.0.0
neighbor 10.1.3.1 remote-as 100
neighbor 10.3.6.2 remote-as 40
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
!
!
!
!
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 192.168.0.4 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 10.2.4.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.4.6.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 10.4.5.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 192.168.0.4
log-adjacency-changes
network 10.4.5.0 0.0.0.3 area 0
network 10.4.6.0 0.0.0.3 area 0
network 192.168.0.4 0.0.0.0 area 0
!
router bgp 40
no synchronization
bgp log-neighbor-changes
network 40.0.0.0
neighbor 10.2.4.1 remote-as 20
neighbor 10.2.4.1 route-map SETLOCPREF in
neighbor 192.168.0.5 remote-as 40
neighbor 192.168.0.5 update-source Loopback0
neighbor 192.168.0.5 route-reflector-client
neighbor 192.168.0.5 next-hop-self
neighbor 192.168.0.6 remote-as 40
neighbor 192.168.0.6 update-source Loopback0
neighbor 192.168.0.6 route-reflector-client
neighbor 192.168.0.6 next-hop-self
no auto-summary
!
ip forward-protocol nd
ip route 40.0.0.0 255.0.0.0 Null0
no ip http server
no ip http secure-server
!
ip as-path access-list 1 permit ^20$
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
route-map SETLOCPREF permit 10
match as-path 1
set local-preference 300
!
route-map SETLOCPREF permit 15
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
!
!
!
!
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 192.168.0.5 255.255.255.252
!
interface Loopback1
ip address 40.5.0.1 255.255.0.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 10.5.6.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.4.5.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 10.5.7.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 192.168.0.5
log-adjacency-changes
network 10.4.5.0 0.0.0.3 area 0
network 10.5.6.0 0.0.0.3 area 0
network 40.5.0.0 0.0.255.255 area 0
network 192.168.0.5 0.0.0.0 area 0
!
router bgp 40
no synchronization
bgp log-neighbor-changes
network 40.0.0.0
neighbor 10.5.7.2 remote-as 50
neighbor 10.5.7.2 route-map SETMED out
neighbor 192.168.0.4 remote-as 40
neighbor 192.168.0.4 update-source Loopback0
neighbor 192.168.0.4 next-hop-self
no auto-summary
!
ip forward-protocol nd
ip route 40.0.0.0 255.0.0.0 Null0
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
route-map SETMED permit 10
set metric 50
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
!
!
!
!
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 192.168.0.6 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 10.3.6.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.4.6.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 10.5.6.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/1
ip address 10.6.7.1 255.255.255.252
duplex auto
speed auto
!
router ospf 1
router-id 192.168.0.6
log-adjacency-changes
network 10.4.6.0 0.0.0.3 area 0
network 10.5.6.0 0.0.0.3 area 0
network 192.168.0.6 0.0.0.0 area 0
!
router bgp 40
no synchronization
bgp default local-preference 200
bgp log-neighbor-changes
network 40.0.0.0
neighbor 10.3.6.1 remote-as 30
neighbor 10.6.7.2 remote-as 50
neighbor 192.168.0.4 remote-as 40
neighbor 192.168.0.4 update-source Loopback0
neighbor 192.168.0.4 next-hop-self
no auto-summary
!
ip forward-protocol nd
ip route 40.0.0.0 255.0.0.0 Null0
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
!
!
!
!
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R7
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 50.0.0.1 255.0.0.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 10.6.7.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.5.7.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 50
no synchronization
bgp log-neighbor-changes
network 50.0.0.0
neighbor 10.5.7.1 remote-as 40
neighbor 10.6.7.1 remote-as 40
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
!
!
!
!
!
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R8
!
ip cef
no ip domain-lookup
no ip icmp rate-limit unreachable
ip tcp synwait 5
no cdp log mismatch duplex
!
line con 0
exec-timeout 0 0
logging synchronous
privilege level 15
no login
line aux 0
exec-timeout 0 0
logging synchronous
privilege level 15
no login
!
!
end
Attachment:
topology.png
Description: PNG image
Archivio con motore MhonArc 2.6.16.