- From: Marco Bonola <
>
- To: "
" <
>
- Subject: lab 22-10-2020 bgp 2
- Date: Thu, 22 Oct 2020 11:33:31 +0200
Dear students,
please find attached the conf files for the today's laboratory.
Ciao
Marco
!
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 1.0.0.1 255.255.0.0
!
interface Loopback1
ip address 1.1.0.1 255.255.0.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 10.0.12.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 1.0.0.0
neighbor 10.0.12.2 remote-as 200
no auto-summary
!
ip forward-protocol nd
ip route 1.0.0.0 255.0.0.0 Null0
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
!
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 2.2.0.1 255.255.0.0
!
interface Loopback1
ip address 2.255.0.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 10.0.12.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.0.25.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 10.0.24.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 2.255.0.2
log-adjacency-changes
network 2.2.0.0 0.0.255.255 area 0
network 2.255.0.2 0.0.0.0 area 0
network 10.0.24.0 0.0.0.3 area 0
network 10.0.25.0 0.0.0.3 area 0
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 2.0.0.0
neighbor 2.255.0.4 remote-as 200
neighbor 2.255.0.4 update-source Loopback1
neighbor 2.255.0.4 next-hop-self
neighbor 2.255.0.5 remote-as 200
neighbor 2.255.0.5 update-source Loopback1
neighbor 2.255.0.5 next-hop-self
neighbor 10.0.12.1 remote-as 100
no auto-summary
!
ip forward-protocol nd
ip route 2.0.0.0 255.0.0.0 Null0
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
!
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 3.0.0.1 255.0.0.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 10.0.35.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 300
no synchronization
bgp log-neighbor-changes
network 3.0.0.0
neighbor 10.0.35.2 remote-as 200
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
!
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 2.4.0.1 255.255.0.0
!
interface Loopback1
ip address 2.255.0.4 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 10.0.24.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.0.45.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 2.255.0.4
log-adjacency-changes
network 2.4.0.0 0.0.255.255 area 0
network 2.255.0.4 0.0.0.0 area 0
network 10.0.24.0 0.0.0.3 area 0
network 10.0.45.0 0.0.0.3 area 0
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 2.0.0.0
neighbor 2.255.0.2 remote-as 200
neighbor 2.255.0.2 update-source Loopback1
neighbor 2.255.0.2 next-hop-self
neighbor 2.255.0.5 remote-as 200
neighbor 2.255.0.5 update-source Loopback1
neighbor 2.255.0.5 next-hop-self
no auto-summary
!
ip forward-protocol nd
ip route 2.0.0.0 255.0.0.0 Null0
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
!
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 2.4.0.1 255.255.0.0
!
interface Loopback1
ip address 2.255.0.5 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 10.0.25.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.0.45.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 10.0.35.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 2.255.0.5
log-adjacency-changes
network 2.4.0.0 0.0.255.255 area 0
network 2.255.0.5 0.0.0.0 area 0
network 10.0.25.0 0.0.0.3 area 0
network 10.0.45.0 0.0.0.3 area 0
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 2.0.0.0
neighbor 2.255.0.2 remote-as 200
neighbor 2.255.0.2 update-source Loopback1
neighbor 2.255.0.2 next-hop-self
neighbor 2.255.0.4 remote-as 200
neighbor 2.255.0.4 update-source Loopback1
neighbor 2.255.0.4 next-hop-self
neighbor 10.0.35.1 remote-as 300
no auto-summary
!
ip forward-protocol nd
ip route 2.0.0.0 255.0.0.0 Null0
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
Attachment:
topology.png
Description: PNG image
- lab 22-10-2020 bgp 2, Marco Bonola
Archivio con motore MhonArc 2.6.16.